#Nix question! So I can't upgrade the package gtk2hs-buildtools-0.13.4.0 because of a cabal version constraint problem. I'm going to report it, but in the meantime how could I update the derivations left to upgrade?

@kwarrtz Yes, but I favor Nix's haskellPackages over Stack because haskellPackages contains binaries, so I don't have the long compilation times 🙂 it's weird, by the way, to have a Cabal error if I'm not supposed to compile anything… 🤔

@otini Binaries are indeed a time saver :) I’m afraid I don’t know enough about haskellPackages to offer much specific help, but would it be possible to build gtk2hs from source and link into it directly in your project?

Sign in to participate in the conversation
Mathstodon

The social network of the future: No ads, no corporate surveillance, ethical design, and decentralization! Own your data with Mastodon!